Skip to main content

Конференции

Просмотр конференции fido7.debate:

Предыдущее Следующее

Дата: 31 Jan 2019, 19:12:12
От: CRAIG STRUTT @ 1:124/5013.0
Кому: All
Тема: RE: Windows 10


Date: Fri, 14 Aug 2015 19:32:02 -0400
From: CRAIG STRUTT
To: MICHAEL PURDY
Subject: RE: Windows 10
Newsgroups: win.server.program
Message-ID: <1439595122.32.1439592234@winserver.com>
References:  <1439592234.32.1439562536@winserver.com>
X-WcMsg-Attr: Rcvd
X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
Lines: 262

It's my own mess of code.   I never learned PHP or MySql truly.   I 
looked at other's code and the manual, and hacked things together.   

I do a lot of Basic Programming, and work with HTML, a little CSS, and 
even some Java.

I'm starting to feel old when I'm not sure I want to learn one more 
thing, which is what happens frequently when you do a major upgrade.

Thanks for your suggestions.   I'll take a look and see if I can figure 
it out.

On 8/14/2015 6:43 PM, MICHAEL PURDY wrote to CRAIG STRUTT:

-> If it is third party PHP application then I would presume the author 
would
-> have a v5 offering unless its abandon-ware. If its your own 
application
-> then it maybe worth considering porting it to WCX/wcODBC.
-> 
-> Before reporting it to HS I would start each of the Wildcat programs
-> manually (in dependency order) and verify that if you do NOT use 
wcStart
-> things run correctly.  
-> 
-> Normally wcStart only misbehaves if there is a problem with the 
"Wait for
-> Up Signal" property associated with one of the applications.  For 
example
-> the wcMail signal Wildcat.MailUpEvent 
-> 
-> I would verify the signal syntax for each of the main applications 
e.g.
-> 
-> Wildcat.MailUpEvent
-> Wildcat.OnlineUpEvent
-> Wildcat.ListServeUpEvent
-> Wildcat.SmtpUpEvent.Router
-> Wildcat.SmtpUpEvent.Sender
-> Wildcat.SmtpUpEvent.Receiver
-> Wildcat.NntpUpEvent
-> 
-> If there is a signal issue wcstart with continue to run waiting for 
the
-> signal and that will then cause issues with the startup of other 
lower
-> level applications.
-> 
-> I would recommend you install SysInternals 
-> 
-> https://technet.microsoft.com/en-us/sysinternals/bb842062
-> 
-> Run 
-> 
-> DBGVIEW.EXE 
-> 
-> Debug Viewer and then run wcStart.exe and you will see what is 
happening in
-> the background at startup.
-> 
-> 
-> 
-> On 8/14/2015 10:28 AM, CRAIG STRUTT wrote to MICHAEL PURDY:
-> 
-> -> Thanks for you help.   Yes, my issues are directly related to 
depreciated 
-> -> commands (mysql_connect).   I'm working through those.    
-> -> 
-> -> I still have two strange issues which I'll have to touch base 
with Hector 
-> -> on.   When the system powers up, WCMail takes up nearly 100% of 
the 
-> -> processor power and WcStart continues to run in the background.   
Although 
-> -> restarting WcMail takes care of it, I've also found (strangely 
enough) that 
-> -> setting it's affinity to 2 CPUs (running a quad core) immediately 
stops the 
-> -> high CPU usage (drops to 0) and then I can put it back on all 
cores and it 
-> -> runs fine.   I've left WcStart running this time (normally I 
force it to 
-> -> stop) and I'm watching it slowly reduce it's memory footprint.   
I want to 
-> -> see if it stops on it's own eventually (a settings issue) or if 
it keeps 
-> -> running.   Right now, it's taking 25% of the CPU cycles.
-> -> 
-> -> On 8/13/2015 6:29 PM, MICHAEL PURDY wrote to CRAIG STRUTT:
-> -> 
-> -> -> Changes to the PHP.INI file are dynamic and do not require any
-> -> -> shutdown/restart with Wildcat!. 
-> -> -> 
-> -> -> If you are using another web server then a restart maybe 
required.
-> -> -> 
-> -> -> Assuming you can connect successfully to MySQL using the CLI 
mysql 
-> -> command
-> -> -> tool or a GUI tool like SQLyog 
https://github.com/webyog/sqlyog-community
-> -> -> then you need to go through the PHP specific troubleshooting 
process.
-> -> -> 
-> -> -> 
-> -> -> 
-> -> -> On 8/13/2015 6:07 PM, CRAIG STRUTT wrote to MICHAEL PURDY:
-> -> -> 
-> -> -> -> Thanks Mike.  I'm *trying* to do just that.   Thus far, the 
shutting 
-> -> -> -> down, and starting up again of the server just to change a 
setting in 
-> -> -> -> PHP.INI is an issue.   
-> -> -> -> 
-> -> -> -> I still don't have the auto shutdown routines working 
correctly, and 
-> -> -> -> the auto startup works on reboot, but not when the machine 
is already 
-> -> -> -> running (can't figure that one out!)  WcStart.exe -run 
works fine in 
-> -> -> -> the scheduler with an ON logon high privilage, but not 
after the 
-> -> -> -> machine is running. <sigh>   I WILL get this.
-> -> -> -> 
-> -> -> -> On 8/13/2015 6:11 AM, MICHAEL PURDY wrote to CRAIG STRUTT:
-> -> -> -> 
-> -> -> -> -> If you check the unsupported branches list
-> -> -> -> -> 
-> -> -> -> -> http://php.net/eol.php
-> -> -> -> -> 
-> -> -> -> -> You will note the 3.x and 4.x has been End of Life for 
many years.
-> -> -> -> -> 
-> -> -> -> -> The expectation when running MySQL 5.x is that you will 
have 
-> -> -> -> migrated to
-> -> -> -> -> PHP 5.x.
-> -> -> -> -> 
-> -> -> -> -> There are differences in the Extensions:
-> -> -> -> -> 
-> -> -> -> -> extension=php_mysql.dll
-> -> -> -> -> extension=php_mysqli.dll 
-> -> -> -> -> 
-> -> -> -> -> used in PHP 3.x, 4.x and 5.x.  They are not compatible.
-> -> -> -> -> 
-> -> -> -> -> I suggest in your PHP.INI you temporarily set
-> -> -> -> -> 
-> -> -> -> -> error_reporting = E_ALL
-> -> -> -> -> display_errors = on
-> -> -> -> -> display_startup_errors = on
-> -> -> -> -> 
-> -> -> -> -> Which when a script is called will show any Startup 
errors such as 
-> -> -> -> DLLs
-> -> -> -> -> failing to load.
-> -> -> -> -> 
-> -> -> -> -> You could of course set the logging to file should you 
prefer.
-> -> -> -> -> 
-> -> -> -> -> error_log = \php\phperror.log
-> -> -> -> -> 
-> -> -> -> -> A simple test script such as
-> -> -> -> -> 
-> -> -> -> -> <?php
-> -> -> -> ->   phpinfo();
-> -> -> -> -> ?>
-> -> -> -> -> 
-> -> -> -> -> Run at the CLI against PHP.EXE e.g.
-> -> -> -> -> 
-> -> -> -> -> php test.php > debug.txt
-> -> -> -> -> 
-> -> -> -> -> Would send all of the information necessary for 
debugging to a
-> text 
-> -> -> -> file
-> -> -> -> -> called DEBUG.TXT
-> -> -> -> -> 
-> -> -> -> -> 
-> -> -> -> -> 
-> -> -> -> -> On 8/12/2015 3:12 PM, CRAIG STRUTT wrote to JERRY SEHL:
-> -> -> -> -> 
-> -> -> -> -> -> I'm up and running on Windows 10 64bit (upgrading 
from XP so a 
-> -> -> -> BIG jump).   
-> -> -> -> -> -> The only problem I am having relates to my MySQL and 
PHP
-> setup.  
-> -> -> -> -> Admittedly 
-> -> -> -> -> -> it's my fault since I was running PHP 4.3 and MySql 
3.4.    I 
-> -> -> -> can't seem to 
-> -> -> -> -> -> get the older PHP to work with a newer (had to 
reinstall)
-> MySql.   
-> -> -> -> I 
-> -> -> -> -> -> remember the configuration was a bear in the 
beginning.   For 
-> -> -> -> that reason, 
-> -> -> -> -> -> since it worked, I didn't touch it.  Now I'm going to 
have to 
-> -> -> -> spend hours 
-> -> -> -> -> -> reading and reconfiguring to get it all back and 
running as it 
-> -> -> -> should be.
-> -> -> -> -> -> 
-> -> -> -> -> -> Not Winserver's problem.  Not Windows 10 problem.  If 
there
-> is a 
-> -> -> -> "best" 
-> -> -> -> -> -> place to start, feel free to point me in that 
direction 
-> -> -> -> (anyone...)
-> -> -> -> -> -> 
-> -> -> -> -> -> On 7/31/2015 3:50 PM, JERRY SEHL wrote to all:
-> -> -> -> -> -> 
-> -> -> -> -> -> -> I installed after a long download, it took a while 
a a bunch 
-> -> -> -> of restarts 
-> -> -> -> -> -> -> until it was ready, however in starting it up with 
my 
-> -> -> -> winserver all 
-> -> -> -> -> -> seemed 
-> -> -> -> -> -> -> well when I received messages and sent some, but 
in checking 
-> -> -> -> my own 
-> -> -> -> -> -> -> websites found they didn't exist.
-> -> -> -> -> -> -> 
-> -> -> -> -> -> -> I made an appointment for a call from MS and 
waited till
-> 5 pm 
-> -> -> -> the next 
-> -> -> -> -> -> day 
-> -> -> -> -> -> -> and viola a phone call but was quickly handed over 
to
-> another 
-> -> -> -> then 
-> -> -> -> -> -> another 
-> -> -> -> -> -> -> where I was on hold for 1 1/2 hours. The service 
tech
-> advisor 
-> -> -> -> quickly 
-> -> -> -> -> -> told 
-> -> -> -> -> -> -> me he didn't understand as it wasn't a Microsoft 
product etc 
-> -> -> -> etc.
-> -> -> -> -> -> -> 
-> -> -> -> -> -> -> A feature to roll back to Windows 7 is built in 
good for 30 
-> -> -> -> days after 
-> -> -> -> -> -> the 
-> -> -> -> -> -> -> upgrade, I used it and all is back well again.
-> -> -> -> -> -> -> 
-> -> -> -> -> -> -> But did find that 32 bit support exists!
-> -> -> -> -> -> -> 
-> -> -> -> -> -> ->  
-> -> -> -> -> ->  
-> -> -> -> ->  
-> -> -> ->  
-> -> ->  
-> ->  
->  
 

--- Platinum Xpress/Win/WINServer v3.1
Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)

Предыдущее Следующее

К списку сообщений
К списку конференций