Skip to main content

Конференции

Просмотр конференции fido7.fidonews:

Предыдущее Следующее

Дата: 18 Jul 2017, 15:24:04
От: Nicholas Boel @ 1:154/10.0
Кому: mark lewis
Тема: Prayer about Putin


On 7/18/2017 7:14 AM, mark lewis -> Nicholas Boel wrote:

 ml> there should be nothing to configure... the file comes with and should
 ml> be correct at the start... the only thing i've done is to add the UTF-8
 ml> things plus adding -keepsoftcr...

I'm not sure what to tell you. In jamnntpd.xlat/xlat.cfg (Linux versus Windows filenames), I use "defaultread CP437", then I have each read line for each specific charset to be translated to UTF-8,
for example:

read  ibmpc  utf-8  437_u8.chs
read  cp437  utf-8  437_u8.chs

I have about 10 of those lines, including latin-1/iso-8859-1 -> UTF-8, cp866, koi8-r, latin-9, cp850 and others (which it seems you have those as well). Then I use "defaultpost UTF-8" and that's
about it for that config.

 ml> EXACTLY my point! that was a quote taken with thunderbird... (al)pine
 ml> and other native news readers do the same...

Are you using an older version of Thunderbird maybe? I believe I'm on the latest.. 52.x or higher. The very last part of my tearline should say so, even though some of it is cut off at the end.

 NB>> I just looked at your STATS postings from yesterday, and they all
 NB>> display just fine here in thunderbird. I have that echo specifically
 NB>> set to be read in cp437 though.

 ml> you've forced that setting in your GROUPS.CFG file??

Yes. While using "defaultread cp437" I see everything posted in the stats echo in exactly what they're posted with (usually the graphs are cp437). So in other echos, like this one, I specify UTF-8 at
the end of my FIDONEWS config line in jamnntpd.groups/groups.cfg. I do this with most of them (mainly any that don't usually include cp437 line and box drawings).

That seemed to be the only way I could read those specific echos properly while keeping my UTF-8 in tact. However, I can't quote any of it properly as it would translate it to UTF-8 - so I don't
(which I believe is why this conversation started in the first place). ;)

 ml> in my GROUPS.CFG file, i have the tagname, group, address, and path... i
 ml> do not have anything else setting any chrs stuff at all... i shouldn't
 ml> have to... all this conversion stuff should be automatic and working out
 ml> of the box...

Sometimes it doesn't. And while you _shouldn't_ have to, sometimes you just have to. ;)

 NB>> Looks like you may have just uncommented the two lines at the top of
 NB>> jamnntpd.xlat and went with the default settings for read and write?

 ml> uncommented what two lines? in my XLAT.CFG, i've only changed the IBMPC
 ml> lines to CP437 and added read and post lines for UTF-8... AFAICR,
 ml> everything else is the same as the default except for my adding
 ml> -keepsoftcr to the read lines...

But you said you were using Western iso-8859-1 in your newsreader? If you use utf-8 post lines in jamnntpd's config, you should probably be using unicode in your newsreader..?

If you want to continue using iso-8859-1, you should probably just use read lines in jamnntpd.xlat to translate everything to that. Then defaultpost would be iso-8859-1 (or latin-1, which only seems
to exist in Fidonet), or whatever you would choose to post with if no charset was specified in a message you're replying to - which is usually cp437.

-- 
Regards,
Nick

--- Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52
Origin: thePharcyde_ distribution system (1:154/10)

Предыдущее Следующее

К списку сообщений
К списку конференций